KiCAD Reference Card

De Techno-Innov Community Wiki
Aller à : navigation, rechercher

1 - Kicad

  • 1.1 - Nouveau projet :
menu "Fichiers --> Nouveau"
raccourci : "Ctrl-N"
  • 1.2 - eeschema :
première icône du gestionnaire de projet
  • 1.3 - Éditeur de bibliothèques de composants :
menu "Outils --> Editeur de Librairies" sous eeschema
icône correspondante sous eeschema
  • 1.4 - cvpcb :
deuxième icône du gestionnaire de projet
menu "Outils --> Associer composants et empreintes" sous eeschema
icône correspondante sous eeschema
  • 1.5 - pcbnew :
troisième icône depuis le gestionnaire de projet
icône correspondante sous eeschema
  • 1.6 - bitmap2component :
cinquième icône depuis le gestionnaire de projet
bitmap2component en ligne de commande.
  • 1.7 - gerbview :
quatrième icône depuis le gestionnaire de projet

2 - Eeschema

  • 2.1 - Options page :
menu "Fichiers --> Ajustage opt page"
quatrième icône de la barre d'outils horizontale
  • 2.2 - Outil de sélection de composants :
troisième icône en partant du haut dans la barre d'outils de droite
menu "Placer -> Composants"
raccourci "Maj + A"
  • 2.3 - Placer le composant en schématique
dernière icone de la barre d'outils horizontale de cette fenêtre (Une feuille blanche avec une flèche blanche: Placer composant en schématique)
  • 2.4 - Déplacer les composants
clic droit sur le composant puis sélection de la première entrée "Déplace Composant P?"
raccourci "M" lorsque la souris est au dessus du composant
  • 2.5 - Outil pointeur :
première icône de la barre d'outils de droite
raccourci "ESC" (Echappement)
  • 2.6 - Annotation automatique :
icone avec la baguette magique ("Annotate Schematic") à côté de la coccinelle dans la barre d'outils horizontale
menu "Outils --> Annotation"
  • 2.7 - Annotation manuelle d'un composant :
clic droit sur le composant puis choix "Édite Composant --> Editer" ou "Édite Composant --> Référence"
raccourci "E" lorsque la souris est au dessus du composant
raccourci "V" lorsque la souris est au dessus de la référence (P?)
  • 2.8 - Éditeur de bibliothèques de composants :
icône "Éditeur de librairie" (un livre ouvert avec un crayon) de la barre d'icônes horizontale
  • 2.9 - Ajout de bibliothèques :
menu "Préférences --> Librairie" (disponible aussi depuis l'éditeur de bibliothèques de composants)
  • 2.10 - Placer des symboles d'alimentation :
quatrième icône de la barre d'outils de droite
menu "Placer --> Power Symbole"
raccourci "Maj + P"
  • 2.11 - Outils Fil :
raccourci "Maj + W"
cinquième icone de la barre de droite
  • 2.12 - Copie d'un élément :
Positionner le curseur sur l'élément puis appuyer sur "C" et déplacer la souris. "Poser" le composant à l'endroit désiré par un clic gauche.
  • 2.13 - Copie par sélection rectangulaire :
maintenir la touche "Maj" enfoncée pour faire la sélection, puis déplacer et coller avec un clic
sélectionner puis faire apparaître le menu de sélection par un clic droit et choisir l'entrée "Copie Bloc" de ce menu
  • 2.14 - Suppression de composants :
positionner la souris au dessus du composant et utiliser la touche "Suppr"
menu "Suppression Composant" du clic droit
menu "Suppression Bloc" du clic droit après une sélection rectangulaire.
  • 2.15 - Symboles de non connexion :
menu "Placer --> Sympole de non connexion"
icone d'une croix bleue dans la barre d'outils de droite
raccourcis "Maj + Q"
  • 2.16 - Labels :
menu "Placer --> Label" ou "Placer --> Label global"
icones avec un A dans la barre d'outils de droite
raccourcis "Ctrl + Alt + L" (global) ou "Maj + L" (local)
  • 2.17 - Texte :
menu "Placer --> Texte graphique"
icone "T" dans la barre d'outils de droite
raccourcis "Maj + T"
  • 2.18 - Feuilles Hiérarchiques :
menu "Placer --> Feuille Hiérarchique"
raccourci "Maj + S"
septième icône en partant du bas de la barre d'outils de droite
  • 2.19 - Sauver bloc :
Sélectionnez tout les éléments avec une sélection rectangulaire, puis utilisez l'entrée "Sauver Bloc" du menu de sélection (clic droit)
  • 2.20 - Navigation entre feuilles hiérarchiques :
double-clic sur la feuille sans outil actif
outil de navigation de hiérarchie
clic droit
menu affichage
icône dans la barre horizontale
  • 2.21 - Copie des éléments sauvegardés :
huitième icone dans la barre d'icônes horizontale: "Copie des éléments sauvegardés" (Le seul moyen que j'ai trouvé)
  • 2.22 - Sélection des unités des composants multipart :
par la boite de dialogue d'édition du composant : liste déroulante en haut à gauche
menu qui s'ouvre lors d'un clic droit sur le composant, sous "Edite composant" --> "Unité"
  • 2.23 - Outil de vérification :
menu "Outils --> ERC"
icone avec une coccinelle dans la barre d'outils horizontale

3 - Éditeur de bibliothèques de composants

  • 3.1 - Créer un composant :
4ème icône de la barre horizontale
  • 3.2 - Ajouter des pattes au composant :
2ème icône de la barre verticale de droite
  • 3.3 - Ajouter des formes :
4ème icône de la barre verticale de droite
  • 3.4 - Sauver le composant dans une nouvelle bibliothèque :
icône de la barre horizontale qui représente un livre ouvert avec une étoile

4 - CvPcb

  • 4.1 - Visualiseur d'empreintes :
quatrième icône de la barre d'outils horizontale
  • 4.2 - Liste filtrée d'empreintes :
avant dernière icône de la barre d'outils horizontale
  • 4.3 - Liste complète d'empreintes :
dernière icône de la barre d'outils horizontale

5 - PcbNew

  • 5.1 - Éditeur de modules :
cinquième icône de la barre d'outils horizontale
  • 5.2 - Options de la page :
quatrième icône de la barre d'outils horizontale
menu "Fichiers --> Ajustage Page"
  • 5.3 - Réglages généraux :
menu "Préférences --> Général"
  • 5.4 - Lecture de la NetListe :
icône avec écrit ".net" dans la barre d'icônes horizontale
menu "Outils --> Netliste"
  • 5.5 - Activer/Désactiver l'affichage une couche :
il faut cocher/décocher la couche correspondante dans le gestionnaire de couches qui se trouve dans la colonne de droite
le gestionnaire de couches peut être masqué/affiché dans le menu "Préférences --> Cacher/Affiche le Gestionnaire de Couches".
  • 5.6 - Outil de tracé de lignes :
menu "Placer -> Ligne ou Polygone"
septième icône dans la barre d'icônes verticale de droite
  • 5.7 - Edition des propriétés d'un module :
menu du clic droit sur le module : "Éditer" dans le sous-menu du module correspondant dans la liste (plusieurs modules peuvent être superposés).
raccourci “E” lorsque la souris est au dessus du module (éventuellement préciser le module concerné)
  • 5.8 - Déplacement d'un module :
menu du clic droit sur le module : "Déplacer" dans le sous-menu du module correspondant dans la liste (plusieurs modules peuvent être superposés).
raccourci “M” lorsque la souris est au dessus du module (éventuellement préciser le module concerné)
raccourci “T”, puis saisir l'identifiant du module.
  • 5.9 - Rotation d'un module :
menu du clic droit sur le module : "Rotation +" ou "Rotation -" dans le sous-menu du module correspondant dans la liste (plusieurs modules peuvent être superposés).
raccourci “R” lorsque la souris est au dessus du module (éventuellement préciser le module concerné)
  • 5.11 - Créer une zone :
menu "Placer --> Zone"
sixième icône dans la barre d'icônes verticale de droite
puis clic gauche à l'endroit ou vous voulez le premier sommet de la zone
choisir les options dans la boite dialogue
placer les sommets suivants et terminer par un double clic ou par le menu du clic droit --> Fermer Contour de Zone.
  • 5.12 - Désactiver l'affichage des zones :
onzième icône dans la barre d'outils verticale de droite.
dixième icône pour le ré-activer
douzième icône pour le mode "contour de zones"
  • 5.13 - Modification des règles de conception (Net Classes) :
menu "Règles de conception --> Règles de conception"
  • 5.14 - Tracer des pistes :
sélectionnez la couche de cuivre active dans le gestionnaire de couches avant de commencer à tracer.
raccourci "Maj + X"
cinquième icône dans la barre d'icônes verticale de droite
menu "Placer --> Piste"
  • 5.15 - Placer des vias :
il est nécessaire d'avoir commencé à tracer une piste (même sans bouger) puis :
raccourci “V”
menu du clic droit --> "Place Via"
  • 5.16 - Suppression d'un segment de piste ou d'une via :
nécessite d'avoir sélectionné l'outil de tracé de pistes.
menu du clic droit sur le segment de piste ou la via : "Supprimer --> Supprimer Segment"
cela permet de ne supprimer que le segment sélectionné, et non pas toute la piste.
il est aussi possible de supprimer tout le "Net" (toutes les pistes qui ont le même numéro de Net).
  • 5.17 - Suppression d'une piste et des vias associées :
les deux xolutions suivantes nécessitent d'avoir sélectionné l'outil de tracé de pistes.
menu du clic droit sur le segment de piste ou la via : "Supprimer --> Supprimer Piste"
raccourci "Suppr" sur un segment de la piste concernée
outil "Supression d'éléments" accessible par l'icône représentant une croix rouge dans la barre d'icônes verticale de droite.
  • 5.18 - Déplacement d'un segment de piste ou d'une via :
nécessite d'avoir sélectionné l'outil de tracé de pistes.
menu du clic droit sur le segment de piste ou la via : "Drag Segments, Garder direction"
menu du clic droit sur le segment de piste ou la via : "Drag Segments"
raccourci "D" pour garder les directions
raccourci "G" pour un déplacement sans garder les directions
  • 5.19 - Compacter les segments et les vias :
menu "Éditer --> Nettoyer Pistes et Vias"
ne pas confondre avec les icônes représentant la même croix rouge dans les barres d'icônes verticales.
  • 5.20 - Changer de couche de PCB active :
clic gauche sur la ligne correspondante dans le gestionnaire de couches pour positionner le curseur bleu devant la ligne.
liste déroulante dans la barre d'icônes horizontale
raccourci "V" pour basculer entre les deux couches de cuivre de la paire de couches de cuivre actives
  • 5.21 - Définition de la paire de couches actives :
menu "outils --> Paire de couches"
icône immédiatement à droite de la liste déroulante dans la barre d'icônes horizontale
  • 5.22 - Vérification des règles de conception :
menu "outils --> DRC"
icône représentant une coccinelle dans la barre d'icônes horizontale
  • 5.23 - Outil texte :
menu "Placer --> Texte"
icône représentant un "T" dans la barre d'icônes verticale de droite
  • 5.24 - Outil d'ajout de cotations :
menu "Placer --> Cote"
icône représentant une cotation dans la barre d'icônes verticale de droite (cinquième en partant du bas)
  • 5.25 - Activer les couches techniques et Auxiliaires :
menu "Règles de Conception --> Options Couches"
  • 5.26 - Marge du masque de vernis épargne (réglage global) :
menu "Dimensions --> Marge Masque des Pads"
  • 5.27 - Génération des fichiers Gerbers :
menu "Fichiers --> Tracer"
  • 5.28 - Export au format SVG :
menu "Fichiers --> Export SVG"

6 - Éditeur de bibliothèques de modules

  • 6.1 - Créer un nouveau module :
5ème icône de la barre horizontale
menu "Fichiers --> Nouveau Module"
  • 6.2 - Déplacer un élément
raccourcis "M"
menu du clic droit sur l'élément --> "Déplace ... "
  • 6.3 - Ajouter une pastille (pad) :
2ème icône de la barre verticale de droite
menu "Placer --> Pad"
  • 6.4 - Éditer les caractéristiques d'une pastille :
raccourcis "E" avec la souris au dessus de la pastille
menu du clic droit sur la pastille --> "Edit Pad"
  • 6.5 - Éditer les caractéristiques des prochaines pastilles positionnées :
avant dernière icône de la barre d'icônes horizontale.
  • 6.6 - Exporter les caractéristiques d'une pastille :
menu du clic droit sur la pastille --> "Exporte Caract. Pads"
  • 6.7 - Appliquer les dernières caractéristiques exportées à une pastille :
menu du clic droit sur la pastille --> "Nouvelles Caract. Pads"
  • 6.8 - Ajouter des formes :
3ème, 4ème et 5ème icônes de la barre verticale de droite
  • 6.9 - Sauver le module dans une nouvelle bibliothèque :
icône de la barre horizontale qui représente un livre ouvert avec une étoile